Browse Source

PIP: Added requirements and modified Manifest

qmlexport
miili 4 years ago
parent
commit
e04fda3a0e
  1. 1
      MANIFEST.in
  2. 3
      maintenance/deploy-pypi.sh
  3. 3
      setup.cfg

1
MANIFEST.in

@ -1,4 +1,5 @@
recursive-include prerequisites *
recursive-include extras *
recursive-include src *.md
recursive-include src/ext/pyavl-1.12 *
include *.md *.tar.gz *.cfg

3
maintenance/deploy-pypi.sh

@ -9,8 +9,6 @@ if [ -z "$branch" ]; then
branch=master
fi
echo "Starting Pyrocko PyPi Deployment Branch $branch"
if [ ! -e ~/.pypirc ] ; then
echo "!! NO ~/.pypirc found !!
Create a ~/.pypirc with the following content:
@ -42,6 +40,7 @@ case $resp in
cd "pip-pyrocko.git"
python setup.py sdist upload -r pypi
cd -
rm -rf "pip-pyrocko.git"
;;
* ) ;;
esac

3
setup.cfg

@ -2,6 +2,9 @@
description-file=maintenance/readme-pip.rst
license-file=LICENSE.md
[options]
requires=files: requirements.txt
[bdist_wheel]
universal=1

Loading…
Cancel
Save